LEARNING OUTCOMES
In this tutorial you will learn about databases in general and about the Access database in particular. The concept of a database is not as easy to grasp as that of a word processor or a spreadsheet. So if this is the first time you are learning about databases you would be well advised to read over the lesson first, away from the computer, and perhaps highlight the text to ease understanding.

Specifically this tutorial will introduce you to the following:
- the general idea behind a database
- planning a new database
- creating a database template
- adding records to a new or existing database
- viewing the data in a database
- clearing entries and records from a database
- making a backup copy of a database

A caveat before you begin: You'll find it easiest to use the tutorial if you follow the directions carefully. On computers there are always other ways of doing things, but if you wander off on your own be sure you know your way back!
7.1 AN OVERVIEW OF THE DATABASE CONCEPT
The database component of MS Office is designed to act as an "intelligent" electronic filing cabinet. Like a manual filing cabinet, it enables you to

- collect sets of related data and keep the data organized;
- update the data once you've collected them, by adding or deleting records and by changing existing records;

An electronic filing cabinet such as a database allows you also to easily and quickly use the data—sort them, create reports, merge the data with other documents, and so forth.

How is a database organized?
Access is an object-oriented relational database management system. The objects that make up any particular database that you create using Access are illustrated in Fig. 7.1.

![Fig. 7.1 The Access database objects](image-url)

---

The word "intelligent" is enclosed in quotes so as not to create a false impression. With regard to computers, the word is overused, and strictly speaking inappropriate. It also can be misleading. The only "intelligence" exhibited by these otherwise "dumb" machines has been programmed into them by intelligent human beings.
• A **Table** is an object which represents the data in rows and columns, rather like a spreadsheet. For this reason, when you view a table in an *Access* database, you are in what *Access* refers to as a *Datasheet View*. You will learn about Tables in this lesson.

• A **Query** is an object which makes a request to the database to find some set of data that is stored in the database. You will learn about queries in Lesson 8.

• A **Form** is an object which gives the user another view of the data in the database. Whereas a Table allows the user to view multiples records at once, a Form displays the contents of just one record at a time. You will learn about Forms in this lesson, too.

• A **Report** is an object which is designed based on the data in the database and which is used to inform the user of the selected contents of the database. You will learn about reports in Lesson 8.

• A **Page** is a special type of web page designed for viewing and working with data from the Internet. This *Access* feature is beyond the scope of these tutorials.

• A **Macro** is a sequence of instructions which can be carried out with a single click of the mouse button on a button in a toolbar or by pressing a key or combination of keys on the keyboard. You may recall developing a *Word* macro in Lesson 6.

• Finally, a **Module** is a collection of programming procedures designed to give programmer control over the *Access* database look and feel.

**A reminder of the general terminology for secondary storage of data**

Words are our stepping stones to knowledge. Personal computers today, for the most part, still use electronic disks as the medium for the secondary storage of data. The Windows computer operating system, like most operating systems, organizes data hierarchically on the disk using documents and directories. Documents are usually stored in directories or subdirectories that are part of the overall directory file management system.

Within documents, different terminology is used to describe the organization of data depending on the type of document in question.

• Word processed documents tend to organize data in paragraphs and sentences;
• spreadsheet documents organize the data in rows and columns;
• database documents organize the data into records and fields.

**The *Access* database terminology in particular**

An *Access* database is able to contain thousands of records; records contain fields; each field contains the raw data called entries made up of characters which are the basic building blocks of data.

For example, let us say you have given a student an assignment to study birds and to build a database to store the data collected. The student decides to set up a record for each bird sighted.

Each record will include field names (*Access* database field names may be up to 63 characters long) such as Common Name of bird, type (Family) of bird, Size, Habitat, etc. A field name such as Common Name of bird might contain the entry "seagull", for example.

A database thus contains records; records have fields; the fields contain entries. These entries are made accessible by the Data View (Table), Form, and Report functions of the *Access* database. At the end of the year, for example, the student would be able to write a relatively
sophisticated report using the word processor, merge into the report the data collected in the database, and even add illustrations of the birds.

It will be useful for you at this stage to see an actual Access database on the computer.

Put your Work Disk in the disk drive, then open the Office Database Management program called Access.

In the New File Task Pane (Fig. 7.2), under Open a file, click on More files…

![Fig. 7.2 The New File Task Pane](image)

Access will display the Open dialog box.

Make sure the drive with your Access Disk in it is the active drive, then double click to open the database document named Birds (Birds.mdb)

**Showing the Full menus and organizing the Toolbars**

In case you're using a computer in a lab or some computer other than your own, you should set the options to Always show full menus, Show the Standard and formatting toolbars on two rows, List font names in their own font, and Show ScreenTips on toolbars.

You may recall doing this at the beginning of all the previous lessons. If the computer you're using doesn't already have these settings, here's what you do.
In the **Tools** menu, select **Customize…**, and in the dialog box that pops up, select the **Options** tab (Fig. 7.3)

![Customize dialog box](image)

**Fig. 7.3 The Customize dialog box**

Make sure there is a **check mark** next to the item to **Always show full menus**

While you’re at it, check the box next to **Show Standard and Formatting toolbars on two rows, List font names in their font, and Show ScreenTips on toolbars**

Click the **Close** button when you’re ready

*Access* displays a dialog box (Fig. 7.4) prompting you to decide how you want to view the data on the screen.

![Database dialog box](image)

**Fig. 7.4 How do you want to view the data in the database?**

Each of the Objects listed in the menu on the left side of the Database dialog box represent one of the objects of the *Access* object-oriented database management system.

You can view the data either as a **form**, record by record, as illustrated in Fig. 7.5.
This Forms view gives you a view of the records one by one. On the other hand, you can view the data as a Table, where the data is displayed in columns or as a list (Fig. 7.6).

Make sure the **Tables Object** button is selected on the **Birds Database** dialog box and the **BirdSightings** table highlighted, then click on the **Open** button in the Birds database toolbar (or just double click on **BirdSightings**).

In the top left corner of the window, in the Title bar, you see the Table name (BirdSightings). In the bottom left corner of the Form and Table View windows are tools to access specific records in the database.
Fig. 7.7 illustrates what each of these navigation tools does.

![Navigation tools in the Access database](image)

As you can see there are 50 records in the database. The field names (Common Name, Family, Size, etc.) are at the top of each column of data. As you can see, the screen is not big enough to allow you simultaneously to see all the records in the Birds database. If you want to scroll through the records or look at any specific record, you have several options:

You can use the scroll bar on the right of the screen to scroll through the records.

Try this now

To move one by one through the records, you can click left or right on the arrows in the access control tools in the lower left corner of the window.

Try this now

To go directly to a specific record, you can select the number of the record you want to view by typing the number of that record in the small data entry box between the arrows.

Try this now to select record 12, and hit Enter

You can select Go To in the Edit menu and go to either the First, Last, Next, or Previous record, or you can opt to create a new record. So much for the nuts and bolts of databases. You are now ready to get your feet wet planning your own database of student records.

In the File menu select Close to close the BirdSightings table, then in the File menu select Close again to close the Birds database

Eject your Work Disk from the disk drive

### 7.2 PLANNING A NEW DATABASE

Before we begin to develop a new database, you need to have at hand the disk on which you're going to save it. You may be using a CD-RW or a zip disk for these tutorials, in which case make sure it is in the disk drive. In Lesson 1, you began by preparing several blank, formatted 1.44 mbyte floppy disks, one of which you named Access Disk. So, if you are using floppy disks, make sure you have this disk ready now to save the documents you will create in Lessons 7 and 8. Also, if you didn't already do so, prepare a second blank, formatted disk for backup purposes. Call this disk Access Disk Backup.

There are three rules of database design: Rule 1—Plan; Rule 2—Plan; Rule 3—Plan.

The more complex the data, the more you need to plan. But even the simplest database should be thought through on paper before being created in Access. Poor planning often results in a database that fails to meet overlooked needs.

Points to ponder when planning a database
The rule of thumb that should guide you is that changes become increasingly difficult to make the further along you go in the process of building a new database. This is true of anything you create. Here, then, are some maxims that you should bear in mind when designing a database.

**Taking your time up front saves time later on**
The database you create will have a long, useful life if you take time to plan it carefully. After you have decided on the fields to include with each record, and **before** you create the database, you should still invest time designing layouts for reports. Thinking about reports will cause you to think about what data you plan to put in the database.

**Teamwork helps**
During the planning stage, run your ideas by others who are familiar with the kind of database you have in mind. Network among your friends. Tell them what you have in mind. Ask them to review your design. You'll be surprised how many valuable ideas they'll come up with that may have escaped you if you had relied on your own resources. Another good idea is to involve your students in the design. This will help them learn skills that will benefit them throughout their lives.

**Keep fields simple**
The more "atomic" your fields the more flexible will be your database. Atomic here means "reduced to its simplest form." The less each field captures in the way of entries the better. For example, in a database of names and addresses, you would keep each part of the person's name as a separate field. The first name should be stored by itself; the same for the middle name and last name. That way you can sort the names by first or last name. You can print a listing last name first or first name last, with or without the middle name, and so on. You will have choices. Lumping the whole name under one field limits your options.

**Design guidelines for a Student Roster database**
You have to build a database for a Student Roster. Let us say that your planning has helped you decide the following about the database and its use:

- The database will be accessible to, and managed by, your students. Each of them will enter their own data at the beginning of the year. You will advise them that they are **not** obliged to fill out every field--that it is OK to leave entries blank. Privacy is an important issue to which our students need to be sensitized. We need to take every opportunity to teach them that they should exercise control over data about themselves. They must make decisions about what is, and is not, privileged information. In a world where, inevitably and increasingly, personal data will be available to whomever wants to use it, our students must learn early on in their lives that they have a responsibility to keep tabs on that data so as to ensure, as far as is humanly possible, that they are correct at all times. Managing their own records on the class database will give them valuable experience in this privacy arena.
- You have drawn up a list of fields (illustrated later in Table 7.1) for each record in the database. Don't start entering them in yet; you still have a couple of things to get clear at this planning stage.
- All the fields will be treated as simple text, except the Date of Birth field, which will be of Date type, and the Brothers and Sisters fields, which will be of Number type. When you declare a field as Date type you can later sort the records in the database chronologically, which has its uses. Likewise, if you declare fields as a Number type you can later sort them numerically. You can also manipulate numeric data mathematically, creating totals, averages, and so forth.
• In your class you will designate one student per week as the database manager. A schedule will be drawn up for this purpose at the beginning of the year. As far as possible, any interaction with the database, including the teacher's interaction, will be monitored by that student unless this is inappropriate for reasons of privacy. Other students may use the database only when the student manager is present.
• The database manager will check the database for items of interest (birthdays, etc.) for the week he or she is in charge, and will interact with the rest of the class to decide how to recognize such items of interest.
• The last activity on the database at the end of each week will be the process of making a backup of the database. This will be necessary because changes to data can occur at any time (a student has a new brother or sister, for example). This would be done by the student database manager under the teacher's supervision.

You could add other features in an actual working environment. With all this in mind, you are ready to create the database which will hold your student records.

### 7.3 SOME HINTS BEFORE YOU CREATE THE DATABASE TEMPLATE

You are going to start a new document for a database of Student Records. You want to save all your personal documents on your own data disks (not on the Work Disk).

Put your **Access Disk** in the disk drive, then from the **File** menu select **New**...

*Access* now presents you with the New File Task Pane as before (Fig. 7.8).

![Fig. 7.8 New File Task Pane](image)

In the Task Pane, click on **Blank Database** to open a new database, then in the **File New Database** dialog box (Fig. 7.9) make sure the **drive in which you have your Data Disk** is the current drive.
Click on the New Folder icon in the File New Database dialog box, name the new folder Database Documents and click on OK.

Type Template for the document name and click on the Create button.

The system knows that this is a new document. This is why you are prompted to begin by creating (defining) a new Table for the database. Notice that the Table object is selected by default on the left side of the dialog box. If you look towards the top of the dialog box, you can see buttons for Open, Design, and New (Fig. 7.10).

Click on the New button to create a new Table in the Template database. Access now displays the New Table dialog box asking you to decide how you want to build the database table (Fig. 7.11).
If you select the *Datasheet View* you will be presented with an empty list of 30 rows and 20 columns as a basis for you to design your new layout. If you select *Design View*, on the other hand, you can go ahead and enter all the fields for the database and specify the data types at the same time. This is what you are going to do in order to learn about data types and data formats at the same time as you build the database.

Select *Design View* in the **New Table** dialog box and click on **OK**

You will now see on the screen the Table Design View dialog box (Fig. 7.12).

*The field names for the new database*

On the screen *Access* is waiting for you to begin typing in the field names. The cursor is located in the first data entry box in the *Field Name* column, prompting you to type in a name for your first field. *Access* field names can be up to 64 characters in Field Size. Before you start entering the field names, however, carefully read what follows so you will have fewer surprises as you go along. Refer back to this section if you need help with any of the specific tasks that follow.
Editing field names You can change the field names after you have committed yourself to them. You can also easily add or clear fields. So at this stage do not worry about making mistakes. If you start typing in a name and realize you have made a mistake before you go on, just use the Backspace key to back up and try again.

Selecting the data type of a field and adding it to the database As illustrated in Fig. 7.12 above, after typing in the field name in the first column, decide what the field's data type should be in the second column.

Setting up predefined entries for a field To reduce the likelihood of bad data getting into the database, you can limit the user's choices when they enter the data for a particular field. For example, when you enter the field Gender, you can limit the choices to M or F and you, or any other user, can simply pick one or the other from a list assigned to the Gender field. In our database, you'll be predefining the City and State fields as well.

7.4 CREATING THE DATABASE TEMPLATE

Entering field names for the database
Table 7.1 contains the complete list of field names for the Student Roster database. You'll be referring to this Table frequently as you work your way through the next several pages, so you might like to mark this page so you can find it easily when you need to.

Type only the Field Names that appear below in the first column of Table 7.1. The second column tell you what Data Type to choose. The other columns in the table below (Required, Field Size and Comments columns) simply explain whether data is to be "Required" for that field from the user and what size (in text characters) the field is allowed to be, along with tips on what to do.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Data Type</th>
<th>Required</th>
<th>Field Size</th>
<th>Comments</th>
<th>Tips to help you as you go along</th>
</tr>
</thead>
<tbody>
<tr>
<td>First Name</td>
<td>Text</td>
<td>Yes</td>
<td>10</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Middle Name</td>
<td>Text</td>
<td>Yes</td>
<td>10</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Last Name</td>
<td>Text</td>
<td>Yes</td>
<td>15</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Home Contact</td>
<td>Text</td>
<td>Yes</td>
<td>20</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Nick Name</td>
<td>Text</td>
<td>No</td>
<td>10</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Gender</td>
<td>Text</td>
<td>Yes</td>
<td>1</td>
<td>Use Lookup Wizard to predefine data</td>
<td></td>
</tr>
<tr>
<td>Address Line 1</td>
<td>Text</td>
<td>Yes</td>
<td>50</td>
<td></td>
<td></td>
</tr>
<tr>
<td>City</td>
<td>Text</td>
<td>Yes</td>
<td>25</td>
<td>Use Lookup Wizard to predefine data</td>
<td></td>
</tr>
<tr>
<td>State</td>
<td>Text</td>
<td>Yes</td>
<td>2</td>
<td>Use Lookup Wizard to predefine data</td>
<td></td>
</tr>
<tr>
<td>Zip</td>
<td>Text</td>
<td>Yes</td>
<td>-</td>
<td>Use input mask to specify the format</td>
<td></td>
</tr>
<tr>
<td>Phone Number</td>
<td>Text</td>
<td>No</td>
<td>-</td>
<td>Use input mask to specify the format</td>
<td></td>
</tr>
<tr>
<td>Date of Birth</td>
<td>Text</td>
<td>Yes</td>
<td>-</td>
<td>Use input mask (Short Date) format</td>
<td></td>
</tr>
<tr>
<td>Brothers</td>
<td>Number</td>
<td>No</td>
<td>-</td>
<td>Long Integer</td>
<td></td>
</tr>
<tr>
<td>Sisters</td>
<td>Number</td>
<td>No</td>
<td>-</td>
<td>Long Integer</td>
<td></td>
</tr>
<tr>
<td>Place in Family</td>
<td>Number</td>
<td>No</td>
<td>-</td>
<td>Long Integer</td>
<td></td>
</tr>
<tr>
<td>Clubs</td>
<td>Memo</td>
<td>No</td>
<td>200</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Hobbies</td>
<td>Memo</td>
<td>No</td>
<td>200</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Favorite Sports</td>
<td>Memo</td>
<td>No</td>
<td>200</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Favorite Subjects</td>
<td>Memo</td>
<td>No</td>
<td>200</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Table 7.1 Template Field Name listing

In the first data entry box in the Field Name column, type the field name First Name and hit Tab to move the cursor over into the Data Type column
Notice, in the lower right section of the window, that *Access* provides help to guide you as you enter the data for each part of each field. Read this help as you go along.

In the lower left corner of the window you can see the *Field Properties* dialog box (Fig. 7.13). In Table 7.1 above, the *Field Size* column specifies the number of characters required for several of the fields in your database.

Check this now so that you know the **correct size** for each field.

Now, look down at the **lower left corner** of the window where you can see a list of **Field Properties**, along with data entry boxes to specify **Field Size**, **Format**, and so forth.

In the **Field Size** box type the number **10** (10 characters)

For the First Name field, and for several other fields (again check out Table 7.1) you want the user to **definitely** fill in an entry—in other words, an entry is **required**. You don’t want the field left blank. Here’s how you can ensure that this happens in your database.

In the **Field Properties** area, **double click** in the data entry box next to **Required** (Fig. 7.13) in order to toggle (switch) the entry from **No** to **Yes**.

Since you are requiring a First Name, you don’t want it to be zero Field Size, so, in the **Field Properties** area, make sure the **Allow Zero Field Size** entry is set to **No**.

Now go back up and click in the next Field Name box below **First Name** so you can enter more database fields.

Enter the field names **Middle Name** (10 characters), **Last Name** (15 characters), **Home Contact** (20 characters), making sure you have **Yes** in the
Required Field Property and No in the Allow Zero Field Size Field Property for each of these fields.

Now enter the field name Nick Name (10 characters), but leave No in the Required Field Property box.

Checking or entering data automatically

Using the Lookup Wizard to specify selected values for a field

For fields such as the Gender, City, and State fields, next in the list of Field Names (see Table 7.1—page 204), the values that should be entered are predictable. For the Gender, it will be M or F; for the City it will be a couple of towns or cities from which your students come; for the State it will be the abbreviation for the state in which you live.

The next series of steps show you how to specify selected values such as this for a field.

Enter the field name Gender in the next Field Name box and hit Tab.

Click on the small triangle (the down arrow) in the Data Type column and select Lookup Wizard... in the drop down list.

In the Lookup Wizard dialog box (Fig. 7.14) click on the radio button next to “I will type in the values that I want”, then click on Next>.

![Fig. 7.14 Opting to enter the values yourself](image)

In the Lookup Wizard (Fig. 7.15), leave the default 1 for the number of columns, hit Tab or click in the data entry box under Col1 and type M.

![Fig. 7.15 Entering the values for the Gender field](image)
Hit Tab or click in the next data entry box in the Col1 column, and type F, then click on Next> to go to the next step in the Wizard.

There’s no need to change the label for the Lookup column (Gender), so click on Finish in the dialog box.

Go back up and click in the data entry box under Gender, type the field name Address Line 1, hit Tab, leave the Field Size as the default of 50 and make it a Required field.

You should use the Lookup Wizard to define a set of data if your students all come from the same one or two towns, a likely scenario in any school district. If you teach in a public school in the US, your students will also all live in the same State. So for the City and State fields you’ll use the same steps as you did to create the Gender field.

Click under Address Line 1, type the field name City, hit Tab, then select Lookup Wizard… for the Data Type and follow the same steps as you just did for the Gender field to enter the names of a couple of your local cities or towns, leave the Field Size as the default of 50 and make it a Required field.

Create the State field with the Lookup Wizard Data type, too, and enter the initials for your state as the value for the list, leave the Field Size as the default of 50 and make it a Required field.

You will see later that the city or cities you name, along with the State, automatically will appear as selections when entering data into those fields in the database.

Using an input mask to control the format for a field

Certain fields always have the same format, like zip codes or phone numbers. You can have Access help you control the way the user enters data for such fields by using an input mask, which forces the user to enter the data a certain way. This reduces the likelihood to some degree of incorrect data getting into the database. Let’s see how this works with the Zip code field, next in the list of Field Names (see Table 7.1—page 204).

Back up in the list of field names, click under State, type the field name Zip Code, then hit Tab.

For the Zip Code you should use a Field Property Input Mask to help the user enter the zip code in the correct format.

In the Field Properties dialog box in the lower left corner of the window, click in the Input Mask box (Fig. 7.16).
Next, click on the **ellipses (...)** that pop up at the end of the data entry box (see Fig. 7.16)

Click on **Yes** to **Save the Table** when Access prompts you to do so, then click on **OK** to accept **Table1** as the default name for the table.

**Primary key or no primary key? that is the question**

Now you are asked to define a Primary Key for the Table. If you were designing the database for an administration application in the Principal’s or Superintendent’s office, this would be an important consideration, because your database would be large, and there would be many ways of looking at the database (called "views" on the data) represented by different tables. The purpose of a primary key is to allow for easy manipulation of the data across multiple tables. This is not something the class teacher needs to worry about, so you won't need a Primary Key for the table.

Click on **No** to tell Access you don't want a Primary Key field in the database.

Now click on the **Zip Code input mask** in the **Input Mask Wizard** dialog box (Fig. 7.17), click on **Try it** to see how the mask will look and enter a zip code with more than 9 digits (the system will beep if you try to do so).

![Input Mask Wizard](image1)

**Fig. 7.17 Zip Code input mask**

Click on **Next>** to proceed to the next step in the Wizard.

The Wizard now asks you in a new dialog box (Fig. 7.18) if you want to change the input mask for the Zip Code and if you want to select a placeholder character which will guide the user when they eventually enter zip codes into the database.

![Input Mask Wizard](image2)
Lesson 7: Introduction to the Access Database

Fig. 7.18 Option to change Zip Code input mask

The underline character is the default, as you can see, so select it as the placeholder character for the Zip Code field, then click on Next> to proceed to the next step in the Wizard.

Click in the radio button to select With the symbols in the mask, like this:, then click on Next> to proceed to the next step in the Wizard, and click on Finish.

Make it a Required field.

You need to follow the same steps to use an input mask for the Phone Number field. Remember to select Text as the data type for the Phone Number. If it is entered as Number type it will be treated as math (numeric) and the hyphen will act as a math operator. In any case, you can only use an input mask with Text or Date/Time data types.

Type the field name Phone Number then click in the Input mask Field Properties data entry box.

Now click on the ellipses (...) that pop up at the end of the data entry box.

Click on Yes to Save the Table when Access prompts you to do so.

Next click on the Phone Number input mask in the Input Mask Wizard dialog box (Fig. 7.17) and click on Try it to see how the mask will look.

The Wizard now again asks you in a new dialog box if you want to change the input mask for the Phone Number and if you want to select a placeholder character which will guide the user when they eventually enter phone numbers into the database.

Click on the underline character to select it as the placeholder character for the Phone Number field.

Click on Next> to proceed to the next step in the Wizard, then click in the radio button to select With the symbols in the mask, like this:

Click on Next> to proceed to the next step in the Wizard, and click on Finish.

Make it a Required field.

For the Date of Birth field, which is next in the listing in Table 7.1 (page 204), you want to select Short Date as the data type for the field, and apply an input mask to the data entry for it, too.

Follow the same steps as you just did for the Zip Code and Phone Number fields, except this time select the Short Date input mask in the Input Mask Wizard dialog box.

Make it a Required field.

Completing definition of the database fields

The remaining fields in the database (Clubs, Hobbies, Favorite Sports, and Favorite Subjects) will all be Memo data type to allow the user to type a longer entry if desired.

When you have completed the entries for all 19 field names click on Close in the window control menu (the little grid-like icon in the top left corner of the Design View window next to Table1).
Click on Yes to tell Access to save the changes you have made to the Table (Table1)

You are now back to the top level dialog box for the Template database. You have defined the database Table which will allow you to start entering the data for a class of students.

### 7.5 COMPLETING PREPARATION OF THE DATABASE TEMPLATE

#### Creating a Form for the new database

The following exercises will help you learn how to prepare a database Form.

A Form is a database object which allows you to view the data one record at a time. This makes a form a convenient tool for data entry purposes because it allows the user to see all the fields in a record at one time, unlike the Table view (the Datasheet View) which will often be unable to show all the columns of data across the screen.

On the left hand side of the Template dialog box, click on the **Forms Object** button

You now have a choice of creating the new form in Design View, which means you'll have to do all the work yourself, or you can use the Form Wizard, which is a lot easier.

Double click on **Create Form by using Wizard** to bring up the **Form Wizard** dialog box

The Form Wizard (Fig. 7.19) is displayed on the screen.

![Fig. 7.19 The Form Wizard dialog box](image)

The Wizard will help you design the Form based on the fields and data types (including input masks) you have selected. You'll begin by telling Access to include all the **Available Fields** for the Form.
**Double click** on each field one by one in the **Available Fields**: list in order to transfer all 19 of them across to the **Selected Fields**: scroll box.

Once you have selected all 19 fields (there should be none left in the left hand side of the dialog box), click on **Next>**.

The Form Wizard now asks what layout you want for the new Form (Fig. 7.20).

![Form Wizard layout options](image)

**Fig. 7.20** The Form layout options dialog box

Columnar layout will work well for our purposes, and that is the default. But check out the sample layouts while you are here by clicking on the radio buttons.

End up with the **Columnar** radio button selected, then click on **Next>** again.

Now the Form Wizard asks you to choose a style or look for the Form (Fig. 7.21).

![Form Wizard style options](image)

**Fig. 7.21** The Form style options dialog box

Click on each of the styles so you can see what options you have, but for this exercise make sure you end up with the **International** style selected, then click on **Next>** again.
In the next dialog box (Fig. 7.22), the Wizard asks you to name the new Form (Form1 will do fine) and also whether you want to modify the design in any way.

![Form Wizard](image)

**Fig. 7.22 Option to modify the form**

In the dialog box for the next step in the Form Wizard, change Table1 to Form1.

Make sure the radio button next to **Modify the form’s design**. is selected, then click on **Finish**.

Access now displays the Wizard’s default layout for the Form (Fig. 7.23).

![Form1: Form](image)

**Fig. 7.23 The basic Form designed by the Wizard**

If necessary, either **move** or **close** the floating Form Design **Toolbox** out of the way so it’s not on top of your Form.
Fig. 7.24 shows the Form after you have rearranged to field names and data entry boxes.

![Form with rearranged fields](image)

**Rearranging the layout of a record in the Form window**

You need to make a few adjustments to the basic Form so that there is enough room for the field names where they are too long to fit in the space allowed by the Form Wizard. You also need to reposition some of the fields to make it easier for the user to enter data into the various data entry boxes. In the exercise that follows, use the dots in the grid to help you align the data entry boxes for each field in the form.

Let's start in the lower right corner of the Form, with the Favorite Subjects field. Fig. 7.25 illustrates how the Favorite Subjects data box will look when you're done adjusting its size.

![Adjusting data entry box](image)

**First click on the Favorite Subjects data box to get the handles around it.**

**Now grab the handle at the bottom center of the box and drag up to make the box about 1/3 smaller** (you don’t need to be too precise about this).
Next grab one of the handles on the right side of the box and reduce the width of the box by about 1/3

Now position the mouse arrow along the lower edge of the box (but not on one of the handles) till it changes into a small black hand, then hold down the mouse button and drag the Favorite Subjects box, along with its Field Name, back down towards the lower right corner of the Form, and tuck it there, as illustrated in Fig. 7.24

This is awkward at first, but you’ll get used to it.

Do the same to the Favorite Sports and Hobbies data entry boxes, resizing them so they’re more or less the same size as the Favorite Subjects box, then move them down and to the right

Next, reduce the Clubs data entry box so it is the same as the others you just changed, then drag the box up and to the right and place it above the Hobbies data entry box

If you did the job correctly, your Memo data entry boxes should all be lined up as illustrated in Fig. 7.26.

![Fig. 7.26 The lined up Memo data entry boxes](image)

Now click on the blue Field Name Favorite Subjects (you can only see “Favorite S”), grab one of the handles on the left and drag the box to the left so it becomes wide enough to show the whole field name

Now that you know what you are doing, readjust and rearrange all the remaining field names and data entry boxes until your Form looks like that illustrated in Fig. 7.24 on page 213
When you have completed the rearrangement of the Form, click in the Close box for the window, then click on Yes when prompted to save the changes to Form1.

Now double click on Form1 in the Template Database dialog box to open it up as a data entry form.

This is where all your hard work pays off. You should see the new form on your screen, and it should look something like Fig. 7.24 above. You can now go ahead and start adding records to the new database.

### 7.6 ADDING RECORDS TO A NEW OR EXISTING DATABASE

#### Creating a new database based on the Template (Importing Objects)

The Access database Template is so named because you want to use this same template document (with its table Table1) and data entry form (Form1) over and over for class records in the years ahead.

Before you start adding data about this year's students, you need to create a new database based on this template document. You will use the new document to store actual student data. The template will remain unchanged for future use.

How you name documents is important. For the sake of this exercise, you're going to call the new database Roster 2002. The name indicates that the document will contain the database of student records for a year 2002 class. If you are currently teaching, you can use a different name if you want to use this tutorial to build an actual database for your own class. Substitute the name you choose for Roster 2002 as you go along.

The Template database should still be displayed on your screen. You can have only one (1) Access database open at a time, so Access will automatically close the Template database when you start to create a new one.

From the File menu select New... and, in the New File Task Pane, click on the Blank Database.

In the File New Database dialog box that pops up, make sure your Access disk is the active disk and that you are inside the Database Documents folder.

Type the new document name Roster 2002, and click on Create.

#### Importing a Table

You are going to start by importing Table1 from the Template database. This will save you having to recreate the table all over again for the new class of students you're doing to put in the Roster 2002 database. This is where all that work on the Template comes in handy. You'll be able to use the Template over and over again for new classes in ensuing semesters or years.

Click on the Tables Object button on the left hand side of the dialog box.

From the File menu, select Get External Data, then from the sub-menu select Import...

In the Import dialog box, double click on the Template.mdb database.

A new dialog box (Import Objects) asks you to specify which table(s) you want to import from the Template.mdb database (Fig. 7.27).
You are asked to confirm that you want to import the Table1 object to the Roster 2002 database.

Table1 is the only table in the database, so click on Select All and click on OK.

Importing a Form

Here are the steps to import Form1 from the Template database.

Click on the Forms button in the Roster 2002 database dialog box, then, from the File menu, select Get External Data > Import...

In the Import dialog box, double click on Template.mdb, then click on Form1 in the Import Objects window and click on OK

The Roster 2002 database now has a Table and a Form identical to the table and form that you created for the Template database. You can add student records to the database any time you like. So if you are not ready to insert new records at this stage, you can close the database. If you want to start entering data now, you can proceed with the tutorial.

Entering the data for the records in the database document

You should still have the Roster 2002 database open.

Click on the Forms button in the Roster 2002 database dialog box, then double click on Form1 to open it.

Remember that each record in the Roster 2002 database is made up of the data for a full set of 19 fields for each student. If you are an in-service teacher, and you want to add the data for all the students in your class, you should practice entering at least one or two records on your own. You might then want to see how your students could handle this job. There are a lot of data for each record after all. If you have a Windows computer in your home room, and you have a copy of Access to use with it, get your students involved in the data entry process. They will enjoy it, and you will be able to delegate an otherwise tedious task.

If you are a student teacher, you may or may not have the opportunity to complete this exercise with a real class. Whatever the case, you will need to enter a few records at this stage (four or five will do nicely for now) so that you can complete the rest of this tutorial.
Begin by selecting the **First Name** field of record #1 by clicking in the data entry box (the cursor is probably waiting there, unless you have already clicked elsewhere).

Type in the **First Name** of one of the students in your roster.

The names don't have to be in any particular order since you can quickly sort them later on. Check the name you just typed. Is it correct?

If so, hit the **Tab** key to proceed to the next field (you'd press **Shift-Tab** if you wanted to move to a previous field).

Notice that the data are now stored in the data entry box for the First Name field in Record 1. If you wanted to correct the data, you would do so by clicking in the data entry box and then make any changes as if you were in the word processor.

Continue entering data for **Record 1** (the data for the first student in the roster); make up the data as you go along if you don't have actual students in mind.

**Adding a New Record to the database**

After you type the last field entry for each record, press **Tab**, and *Access* will automatically present a **new record Form**.

*Access* will also automatically save each completed record into the database on your disk, so you don't have to worry about losing your work as you go along, and you also won't need to save the database at the end.

Type the entries into each field one by one; be sure to press the **Tab** key after each entry to get to the next field (eventually you should have at least 4 or 5 records in the Roster 2002 database).

Adding a record to an existing database is just the same. New records are always added at the end of the database. If you want the new record to appear in a specific place in the Datasheet view you would use the Sort function. You'll learn how to do this in Lesson 8.

The new record will always have the same layout and format characteristics as the others in the database.

**7.7 VIEWING THE DATA IN THE DATABASE**

At this time, you should learn some of the ways to move about in a database. *Access* makes it easy for you to get around. Take a few moments to move from field to field and from record to record. Try these exercises.

Click anywhere in the **data box** next to a **field name**.

This allows you to edit or add data if needed.

Hit the **Tab** key to move to the **next field** in the **same record**.

To move to the **same field** in the **next** or **preceding record**, click on the left or right arrows in the **Navigation tools** at the bottom of the Form window (Fig. 7.28).
To move quickly through the database as a whole, it's easiest to use the *Datasheet (Table) view* of the database, so…

In the **View** menu (Fig. 7.29) select **Datasheet View** now to see how you can view all the records in one window.

Scroll up and down and from left to right to get a feel for how to check out the records (rows) and fields (columns) of data that make up the database of student records.

Close the **Datasheet View** window on **Table1**

In Lesson 8 you will learn other ways of searching through the database, other ways of selecting sets of records from the database, and so forth. For now, as a final exercise in Lesson 7, let's just learn how to update the data in an *Access* database.

### 7.8 UPDATING ENTRIES AND RECORDS IN THE DATABASE
The following exercises will give you the opportunity to practice working with the data in a database.

**Updating the contents of a field (one item of data in a record)**

From the View menu, select **Database Objects > Forms**

**Double click on Form1**

To clear (delete), or otherwise change the contents of a field in a record, click on the field data entry box, then erase characters or words in the same way as you would if you were in the word processor.

**Deleting (clearing) a record**

In order to delete a single record from a database, you would select the record that you want to remove, then select Delete Record from the Edit menu, and voilà!

Try this for practice.

Click on the **second record** in the **Roster 2002** database to select it

From the Edit menu select **Delete Record**

*Access* will warn you that you are about to delete a record and tell you that you will not be able to undo the deletion. This gives you the opportunity to change your mind, which you must do in this case, because *Access* will otherwise immediately permanently remove the record if you click on *Yes*.

Click on **No** in the dialog box

**Deleting several records at once**

You can use the Datasheet View to clear several records that are listed next to each other. To delete several records at one time here’s what you do.

You need to be in the **Datasheet View** of the database, so from the View menu select **Datasheet View**

Now drag in the **left hand margin** of the Table to **highlight** as many **adjacent records** as you want to delete

From the Edit menu, select **Delete Record**

The database will warn you that you are about to delete however many records you have selected, and will ask you if you are sure you want to do this

And you would go ahead and delete the records or not depending on what you want to do. Notice that the Delete Record command completely removes a record, such that it is irretrievable.

### 7.9 SAVING A BACKUP COPY OF YOUR WORK

Your last task before completing this session at the computer is to make a backup of your Template and Roster 2002 databases on another disk. The Roster 2002 database is still on the Desktop. Both databases are also saved on your *Access Disk*, which is in the disk drive.

Close the Access database program
Close or minimize any other windows that may be open on your desktop to make it easier for you to see what you’re doing.

Double click to open the My Computer icon, then double click on the drive that contains your Access Disk.

Now drag the folder Database Documents from your Access Disk to the Desktop and drop it there.

Watch while Windows makes a copy of your documents on to the desktop, then close the window on your Access Disk.

Remove your Access Disk from the disk drive, replace it with your Access Disk Backup and double click to open the disk drive window.

Now drag the Database Documents folder from the desktop to your Access Disk Backup.

LOOKING BACK
You have learned how to build an Access database. The concepts that have been covered in this tutorial apply in general to all computer-based databases. You have to plan first. Then you have to define, or set up, the database, telling the system what fields you need in each record. This done, you enter the data for each record and save everything on the disk.

You practiced scanning the database in multiple (Datasheet or columnar) or single (Form) record layout. You also learned how to clear records and change entries. Finally you learned how to save a copy of a database onto your Data Backup disk.

LOOKING FORWARD
There is a great deal more to learn about the Access database, especially with regard to searching for specific sets of data, sorting (arranging) data, and producing various types of reports. Lesson 8 will provide you with the opportunity to practice these skills.

SKILL CONSOLIDATION
Complete these exercises to reinforce what you have learned in Lesson 7.

1. Design and create a database for the names, addresses, and telephone numbers you have in your address book. Enter as many names and addresses as you like (as long as you have at least 6). Don’t forget to save the database records as you go along.

2. Add a couple of records to the database you created in exercise 1. Clear a record.

3. Add a field to the address book database--say Association (how are the people associated to you--friend, colleague, etc.). Then enter the data for each record for the new field.

4. Imagine you are teaching a class and you want your students to do research on a topic. Design and create a database around that topic. You could discuss the fields with your students. The students would then go off, do the research, and enter the data into the database as a basis for a paper they must prepare. This would be a nice group (team) exercise.
5. Design and create a database for a Birthday List of your family and friends. Include fields such as Name, Birthday, Greek sign, Favorite color, Clothes sizes, Hobby, etc. Have at least 6 records in the database, with each record containing at least 5 fields.

6. Open the *Access* database Roster 2002 and enter a complete new record for a student named Jane Doe.

7. Open the *Access* database named Template. Change the name to Grade X.2002 so you won't lose the template, and add three (3) records. Then save the updated database.